المساعد الشخصي الرقمي

مشاهدة النسخة كاملة : [ شرح ] كيفية تحديد سرعه معينه للدونلود والباقي للتصفح (هوتسبوت)



سمسمة
12-12-2012, 02:03 PM
كود - مايكروتيك -ك ود منع التحميل - كودات المايكروتيك-برامج شبكات سلكية 2012 - كيفية التحكم فى الشبكات - سيسكو - برامج سيسكو 2012 مج عمل سكان للشبكة -- شبكات سلكية - برنامج cna - تعلم التحكم بالشبكات -برامج ادارة الاجهزة - التحكم بالشبكات من سيسكو - تعلم الشبكات السلكية 2012

http://www.enjaztech.com/up/i/00012/x68rpfqxqfd2.gif (http://www.enjaztech.com/vb/t35*9*.html)

http://www.enjaztech.com/up/i/00010/3o985keb5lxu.gif (http://www.enjaztech.com/vb/t36859.html)
كنت عامل نفس الموضوع لل برودباند اللي انا شغال بيه الحمد لله تمام بس معظم الناس شغاله هوت سبوت
الفكره هنا مش اني اخلي الدونلود علي خط والتصفح علي خط تاني لا
انا هنا لو عندي مثلا 4 ميجا سواء كان خط واحد او اكتر من خط مش هتفرق لان الفكره اني هحدد سرعه معينه للدونلود تتوزع بالتساوي بين المشتركين او تحديد سرعه معينه لكل مشترك والمجموع مش يزيد عن اللي انا محدده
المثال هنا هنفرض ان في سرعه 4 ميجا هخلي 1 ميجا للدونلود والباقي للتصفح
الاعدادات دي بتكون علي سيرفر التوزيع سواء كان لوحده او عليه دمج وتوزيع

http://www.enjaztech.com/up/i/00015/zcu22rlq3wce.gif

اولا: هحدد كل الملفات اللي ممكن المشترك يعملها دون لود زي exe,rar,mvi,mp3,flv...........
هنضيف الكود دا



كود PHP:

/ip firewall filter
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.mov content=.mov disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=SWF content=.swf disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.mp4 content=.mp4 disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=mp3 content=.mp3 disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.ra content=.ra disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.rm content=.rm disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=wma content=.wma disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=wmv content=.wmv disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=dat content=.dat disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=AVI content=.avi disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=RAM content=.ram disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=FLV content=.flv disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=mp4 content=.mp4 disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=3gp content=.3gp disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.iso content=.iso disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.exe content=.exe disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.msi content=.msi disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=MVI content=.mvi disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=rar content=.rar disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=ZIP content=.zip disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.cab content=.cab disabled=no protocol=tcp
add action=add-dst-to-address-list address-list=download-files address-list-timeout=1h chain=forward comment=.mkv content=.mkv disabled=no protocol=tcp





http://www.enjaztech.com/up/i/00015/zcu22rlq3wce.gif
ثانيا
هنحدد الترافيك اللي داخل لكارت ال WAN
الكود دا لو عندك كيسه توزيع واخري دمج او عند كيسه واحده عليها خط واحد
كود PHP:

/ip firewall mangle
add action=mark-packet chain=prerouting disabled=no in-interface=wan new-packet-mark=download-files-packets passthrough=no protocol=tcp src-address-list=download-files



http://www.enjaztech.com/up/i/00015/zcu22rlq3wce.gif

لو عندك سيرفر واحد عليه دمج وتوزيع تكتب الكود دا مع العلم بان اسم الكروت WAN1 ,WAN2,WAN3
وطبعا اللي عنده كارتين بس يمسح السطر بتاع WAN3
كود PHP:

/ip firewall mangle
add action=mark-packet chain=prerouting disabled=no in-interface=WAN1 new-packet-mark=download-files-packets passthrough=no protocol=tcp src-address-list=download-files

add action=mark-packet chain=prerouting disabled=no in-interface=WAN2 new-packet-mark=download-files-packets passthrough=no protocol=tcp src-address-list=download-files

add action=mark-packet chain=prerouting disabled=no in-interface=WAN3 new-packet-mark=download-files-packets passthrough=no protocol=tcp src-address-list=download-files


http://www.enjaztech.com/up/i/00015/zcu22rlq3wce.gif

ثالثا ال queue بطريقه PCQ
كود PHP:

/queue type
add kind=pcq name=files-download pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10m pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000


http://www.enjaztech.com/up/i/00015/zcu22rlq3wce.gif

هنا انا مش محدد سرعه ثابته لليوزر بمعني لو واحد لوحد هيعمل دون لود ب 1 ميجا ولو اتنين كل واحد ب 512 وهكا .
لو عايز تحدد سرعه ثابته لليوزر حتي لو لوحده مش يعديها ودا انا بفضله علشان سياسة الاستخدام العادل تغير ال pcq-rate=128k مثلا بدل pcq-rate=0


http://www.enjaztech.com/up/i/00015/zcu22rlq3wce.gif

اخر خطوه وهي تحديد السرعه الكليه للدونلود
كود PHP:

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=download-files packet-mark=download-files-packets parent=global-out priority=8 queue=files-download


ممكن تغير طبعا الواحد ميجا للي انت عايزه غير max-limit=2M لو عايز تحدد للدونلود 2 ميجا

الموضوع الحمد لله متجرب وشغال تمام
منقول للاستفادة